Brand Insights Dashboard and API Dashboard outage
Incident Report for LogoGrab
Resolved
Brand Insights Dashboard and API Dashboard are now fully operational
Posted about 2 years ago. May 03, 2017 - 23:24 IST
Investigating
Irregularities in Data Warehouse are being investigated
Posted about 2 years ago. May 03, 2017 - 15:43 IST